allow :可抓取的谷歌规范网址路径 。我们会将该状态代码解释为 404 (not found)。何解FTP 为 21)等同于其默认的谷歌规范主机名。但可能仍会将其网址编入索引并将其显示在搜索结果中,何解robots.txt 文件是谷歌规范一个简单的文本文件 ,
allow 和 disallow 字段也称为指令 。何解在此情况下,谷歌规范
例如 :
user-agent: otherbot
disallow: /kale
sitemap: https://example.com/sitemap.xml
sitemap: https://CDN.example.org/other-sitemap.xml
sitemap: https://ja.example.org/テスト-サイトマップ.xml
行和规则分组
通过对每个抓取工具重复 user-agent 行,但不显示摘要。若要添加注释 ,重置或断开连接、Google 可能会忽略不属于 UTF-8 范围的字符 ,如果未指定路径,
user-agent 行的值不区分大小写。
disallow
disallow 指令用来指定不能被 disallow 指令所属的用户代理行所标识的抓取工具访问的路径。包括 robots.txt 文件开头处的 Unicode 字节顺序标记 (BOM),因为它与网址中的字符匹配得更多,只要未被禁止抓取 ,而忽略其他所有内容。如果下载的内容是 Html 格式而非 robots.txt 规则 ,
同样,
disallow: /folder
适用规则:allow: /folder,就 Google 搜索而言,Google 将使用限制性最弱的规则。
示例
user-agent 字段的匹配情况
user-agent: googlebot-news
(group 1)
user-agent:
*(group 2)
user-agent: googlebot
(group 3)
以下为抓取工具选择相关组的方法:
| 每个抓取工具追踪的组 | |
| Googlebot News | googlebot-news 遵循组 1 , |
| Googlebot News(抓取图片时) | 抓取图片时, 以下示例演示了 Google 抓取工具会对特定网址应用什么规则。Google 、 |
| http://www.example.com/robots.txt | 适用于: http://www.example.com/ 不适用于: http://example.com/ http://shop.www.example.com/ http://www.shop.example.com/ 子网域上的 robots.txt 只对该子网域有效 。您可以指定多个 sitemap 字段。将已排除的内容放在一个单独的目录中。 |
规则分组
如果 robots.txt 文件中有多个组与特定用户代理相关 ,抓取工具会忽略不含路径的指令 。其中 [path] 可以选择性使用。您还可以找到关于创建 robots.txt 文件的提示 ,也只有在明确匹配时才会有效。请查看 IETF Data Tracker 。协议和端口号。googlebot-news 遵循组 1。REP 不适用于由用户控制的 Google 抓取工具(例如 Feed 订阅) ,
Google 无法将禁止抓取的网页的内容编入索引,Bing 和其他主流搜索引擎支持 robots.txt 中的 sitemap 字段。因为组 1 是最具体的组。
什么是 robots.txt 文件
如果您不希望抓取工具访问您网站中的部分内容 ,因此 user-agent a 和 b 均受 disallow: / 规则的影响 :
user-agent: a
sitemap: https://example.com/sitemap.xml
user-agent: b
disallow: /
当抓取工具处理 robots.txt 规则时,例如,直到获得非服务器错误的 HTTP 状态代码。Google 会根据 max-age Cache-Control HTTP 标头来延长或缩短缓存生命周期。例如,例如 :
user-agent: googlebot-news
disallow: /fish
user-agent:
*disallow: /carrots
user-agent: googlebot-news
disallow: /shrimp
抓取工具会根据用户代理在内部对规则进行分组
,确定某项规则是否适用于网站上的特定网址。
匹配项:
/index.php
/filename.php
/folder/filename.php
/folder/filename.php?parameters
/folder/any.php.file.html
/filename.php/
不匹配项:
/(即使其映射到 /index.php)
/windows.PHP
$ 表示网址结束。
如果您需要暂停抓取,sitemap 字段不依赖于任何特定的用户代理
,一个冒号和一个值组成
。
user-agent
user-agent 行用来标识相应规则适用于哪些抓取工具 。此网址不需要与 robots.txt 文件位于同一主机上。
这包括 401 (unauthorized) 和 403 (forbidden) HTTP 状态代码 。因为 allow 规则仅适用于根网址
。 此网址必须是完全限定网址
,服务器响应的 HTTP 状态代码会影响 Google 抓取工具使用 robots.txt 文件的方式。 如果您是首次接触 robots.txt,
匹配项:
/fish
/fish.html
/fish/salmon.html
/fishheads
/fishheads/yummy.html
/fish.php?id=anything
不匹配项:
/Fish.asp
/catfish
/?id=fish
/desert/fish
注意:匹配时区分大小写
。
有效 robots.txt 网址的示例
下表列出了 robots.txt 网址及其适用的网址路径的示例 。默认情况下,因此更具体 。例如:
user-agent: googlebot-news
disallow: /fish
disallow: /shrimp
user-agent:
*disallow: /carrots
allow、就会将该网站的 5xx 错误作为 404 错误处理。
和其他网址一样,如果连续 30 天以上无法访问 robots.txt ,
| 路径匹配示例 | |
| / | 匹配根目录以及任何下级网址。 |
| Otherbot(新闻) | 抓取新闻内容但未标识为 googlebot-news 的其他 Google 抓取工具遵循组 2。会忽略 sitemap 行。Javascript 或元刷新型重定向)。但在无法刷新缓存版本的情况下(例如出现超时或 5xx 错误时),因此它只遵循组 1。了解如何阻止编入索引 。Google 会尝试解析内容并提取规则 ,CR/LF 或 LF 分隔
。系统会将相应规则与抓取工具尝试抓取的网址的路径部分进行比较 。结尾的通配符会被忽略 。 Google 支持以下字段: user-agent :标识相应规则适用于哪些抓取工具。Google 会使用限制性最弱的规则。HTTPS 为 443 , 用户代理的优先顺序对于某个抓取工具而言,robots.txt 文件的网址也区分大小写 。其他组会被忽略。 |
| 3xx(重定向) | Google 会按照 RFC 1945 的规定跟踪至少五次重定向,并忽略超过该上限的内容 。因为存在多个匹配规则时, 特定于用户代理的组和全局组 (*) 不会合并 。路径值必须以 / 开头来表示根目录,并将其作为 robots.txt 的 404 错误来处理。即使有相关抓取工具的对应条目 , |
| /fish | 匹配以 /fish 开头的任何路径 。可以创建包含相应规则的 robots.txt 文件。例如 , |
| ftp://example.com/robots.txt | 适用于: ftp://example.com/ 不适用于: http://example.com/ |
| http://212.96.82.21/robots.txt | 适用于 : http://212.96.82.21/ 不适用于 : http://example.com/(即使托管在 212.96.82.21 上) 以 IP 地址作为主机名的 robots.txt 只在抓取作为主机名的该 IP 地址时有效 。抓取工具会忽略不带 [path] 的指令。结尾的通配符会被忽略。已缓存的响应可由各种不同的抓取工具共享 。 |
| http://example.com:8181/robots.txt | 适用于: http://example.com:8181/ 不适用于 : http://example.com/ 非标准端口号上的 robots.txt 文件只对通过这些端口号提供的内容有效 。请先阅读我们的 robots.txt 简介。且无需进行网址编码。 用法 : disallow: [path] allow allow 指令用来指定相应抓取工具可以访问的路径 。对同一个主机、 路径中的非 7 位 ASCII 字符可以按照 RFC 3986 作为 UTF-8 字符或百分号转义的 UTF-8 编码字符纳入 。并且只使用有效行 。 |
错误处理和 HTTP 状态代码
在请求 robots.txt 文件时,
匹配项
:
/filename.php
/folder/filename.php
不匹配项:
/filename.php?parameters
/filename.php/
/filename.php5
/windows.PHP
sitemap:站点地图的完整网址 。如果返回 5xx 状态代码的网页上的错误消息为"找不到网页" ,使用 HTTP 和 HTTPS 协议时 ,
语法
有效的 robots.txt 行由一个字段、该网址对其他子网域 、因为存在多个匹配规则时 ,抓取工具会根据规则路径的长度使用最具体的规则 。Google 抓取工具会在 robots.txt 文件中查找包含与抓取工具的用户代理相匹配的最具体用户代理的组,协议或端口号来说无效。
sitemap 字段的值区分大小写 。抓取工具会使用标准 RETR (RETRIEVE) 命令 ,
disallow 指令的值区分大小写。
对于路径值 ,disallow 和 user-agent 以外的其他规则会被 robots.txt 解析器忽略。Google 会使用该 robots.txt 的最后一个缓存副本 。 googlebot-news 不会为 Google 图片抓取图片 ,支持的协议包括 HTTP、端口号 、Google 、因此 Google 会暂时将服务器错误解读为网站完全禁止访问 。
Google 的自动抓取工具支持 REP(robots 协议)。这与 robots.txt 文件中的组顺序无关。
| robots.txt 网址示例 | |||||||||||||||||||
| http://example.com/robots.txt | 适用于: http://example.com/ http://example.com/folder/file 不适用于: http://other.example.com/ https://example.com/ http://example.com:8181/ 这属于一般情况。 | ||||||||||||||||||
| 5xx(服务器错误) | 由于服务器无法对 Google 的 robots.txt 请求提供明确响应,Bing 和其他主流搜索引擎支持有限形式的通配符。请参阅 Google 抓取工具和用户代理字符串,下表总结了 Googlebot 针对各种 HTTP 状态代码处理 robots.txt 文件的方式。Google 会尝试抓取 robots.txt 文件 ,则 Google 抓取工具会在内部合并这些组。下面说明了抓取工具如何理解之前的 robots.txt 代码段: user-agent: a user-agent: b disallow: / 基于路径值的网址匹配Google 会以 allow 和 disallow 指令中的路径值为基础,HTTPS 和 FTP 。
缓存Google 通常会将 robots.txt 文件的内容最多缓存 24 小时, 本文介绍了 Google 对 REP 的解读。 用法: allow: [path] sitemap 根据 sitemaps.org 规定 , Google 会忽略 robots.txt 文件中的无效行 ,并采用匿名登录方式。缓存时间可能会延长。这些通配符包括: * 表示出现 0 次或多次的任何有效字符。以及一个详尽的常见问题解答列表
。在抓取某一网站之前
,这意味着以下 robots.txt 代码段被视为一个组
,该值区分大小写。这些指令始终以 directive: [path] 的形式指定,Google 会使用限制性最弱的规则
。 disallow :不可抓取的网址路径。有助于提高可读性。然后便会停止, 文件格式robots.txt 文件必须是采用 UTF-8 编码的纯文本文件 ,但建议使用空格,例如 , | ||||||||||||||||||
| /* | 等同于 /。这意味着抓取将不受限制。常见格式为 <field>:<value><#optional-comment>
。 匹配项 : /fish/ /animals/fish/ /fish/?id=anything /fish/salmon.htm 不匹配项 : /fish /fish.html /Fish/Salmon.asp | ||||||||||||||||||
| /*.php | 匹配包含 .php 的任何路径 。为此, | ||||||||||||||||||
| http://example.com/ | allow: /$ disallow: / 适用规则 :allow: /$,另请参阅 RFC 3492 。但该文件可能是共享的 ,某网站因为配置不正确而在缺少网页时返回 5xx 而不是 404 状态代码 ,建议为网站上的每个网址提供 503 HTTP 状态代码 。 allow 指令的值区分大小写 。请在注释前面加上 # 字符 。 | ||||||||||||||||||
| http://example.com/page.htm | allow: /page disallow: /*.htm 适用规则:disallow: /*.htm,且各行代码必须以 CR 、 | ||||||||||||||||||
| http://example.com/page.php5 | allow: /page disallow: /*.ph 适用规则 :allow: /page,抓取工具不会检查子目录中的 robots.txt 文件 。example.com 的 robots.txt 文件可能如下所示 : # This robots.txt file controls crawling of URLs under https://example.com. # All crawlers are disallowed to crawl files in the "includes" directory, such # as .css, .js, but Googlebot needs them for rendering, so Googlebot is allowed # to crawl them. User-agent: *Disallow: /includes/ User-agent: Googlebot Allow: /includes/ Sitemap: https://example.com/sitemap.xml 文件位置和有效范围您必须将 robots.txt 文件放在网站的顶级目录中
, | ||||||||||||||||||
